Tuesday, September 7, 2010

OL - MPLS Label filtering

Notes:

Atleast 2 ways to accomplish label filtering, meaning appending label to prefix. Outbound filtering and Inbound filtering.

Configs:
Outbound Filtering
no mpls ldp advertise-labels
mpls ldp advertise-labels for 51 to 50

Access List 51 is ACL for the prefixes and ACL 50 is the ACL for the LDP neighbor

Inbound Filtering
mpls ldp neighbor 1.1.1.1 labels accept 99

Access List 99 is the ACL for the prefixes

Thursday, September 2, 2010

OL - L2TPv3

Notes:

The difference between AToM and L2TP is that AToM is over an MPLS network whereas L2TP is over straight IP.

The concepts are very similar. The CE facing interfaces on the PEs need to create a VC across IP (for L2TP or MPLS for AToM). This requires pseudowires to make that connection.

With both AToM, the use of LDP neighbor/peer of the remote PE is used but in L2TP, under the pseudowire-class, you need to define a ip local inteface loop 0. And then use the peer's loopback as the xconnect's peer.

Config:

R3 - PE
l2tp-class L2TP
authentication
password 7 047822352C0E
!
pseudowire-class L2TP
encapsulation l2tpv3
protocol l2tpv3 L2TP
ip local interface Loopback0
!
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
no cdp enable
no clns route-cache
xconnect 4.4.4.4 12 pw-class L2TP

OL - ATOM

Notes:

I've created my own lab to test out the different types of Layer 2 protocols I can transport over MPLS.

There are, at a basic level, 2 parts to enabling AToM. First, create a pseudowire-class and second, create the VC via an xconnect statement under the CE facing interface on the PE.

Of course, the prerequisite for this to work is that MPLS is enabled throughout the core network.

Also, note that to make life easier use 'mpls ldp router-id loop 0 force'. You have to designate the other PE as peer in xconnect which will be the ldp router id.

Layer 2 protocols that can be transported are EoMPLS, FRoMPLS, PPPoMPLS, HDLCoMPLS, and ATMoMPLS (can't emulate in dynamips, as the PA-A1 doesn't support it).

Config:

R3 - PE
mpls ldp router-id Loopback0 force
mpls label protocol ldp
pseudowire-class EOMPLS
encapsulation mpls
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet1/0
ip address 150.1.35.3 255.255.255.0
duplex auto
speed auto
mpls ip
no clns route-cache
!
interface FastEthernet1/1.100
description EoMPLS
encapsulation dot1Q 100
no cdp enable
xconnect 4.4.4.4 100 pw-class EOMPLS
!
interface Serial2/0
description HDLCoMPLS
no ip address
serial restart-delay 0
no cdp enable
no clns route-cache
xconnect 4.4.4.4 67 pw-class EOMPLS
!
interface Serial2/1
description FRoMPLS
no ip address
serial restart-delay 0
no cdp enable
no clns route-cache
xconnect 4.4.4.4 607 pw-class EOMPLS
!
interface FastEthernet3/0
ip address 150.1.34.3 255.255.255.0
shutdown
duplex auto
speed auto
mpls ip
no clns route-cache
!

CE config
The CE's are generally configured like back to back CE to CE connections with nothing but a pseudo wire connecting the two. * Remember for FRoMPLS though, you'll want once side to act as Frame switch and that interface to be DCE.