The overall idea of Carrier Supporting Carrier (CsC) is that you are utilizing another carrier as a backbone network, ie, using their footprint.
Task 19.5 - Configure IPv4 eBGP on R5 and R2... advertise its MPLS label
Config:
R5#sh run | sec bgp
mpls bgp forwarding
router bgp 156
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.50.25.2 remote-as 2
neighbor 200.0.0.6 remote-as 156
neighbor 200.0.0.6 update-source Loopback0
!
address-family vpnv4
neighbor 200.0.0.6 activate
neighbor 200.0.0.6 send-community extended
exit-address-family
!
address-family ipv4 vrf CSC
neighbor 150.50.25.2 remote-as 2
neighbor 150.50.25.2 activate
neighbor 150.50.25.2 send-label
no synchronization
exit-address-family
The highlighted config shows using IPv4 eBGP to send mpls labels while the next task simply asks you to configure ldp.
Task 19.6 - Configure OSPF... LDP on the link between R6 and R8
Config:
R6#sh run | sec bgp
redistribute bgp 156 subnets
router bgp 156
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 200.0.0.5 remote-as 156
neighbor 200.0.0.5 update-source Loopback0
!
address-family vpnv4
neighbor 200.0.0.5 activate
neighbor 200.0.0.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CSC
redistribute ospf 1 vrf CSC
no synchronization
exit-address-family
alias exec sb sh ip bgp
alias exec cb clear ip bgp *
R6#sh run int f1/1
Building configuration...
Current configuration : 128 bytes
!
interface FastEthernet1/1
ip vrf forwarding CSC
ip address 150.50.68.6 255.255.255.0
duplex auto
speed auto
mpls ip
end
R6#
Notice there's no bgp peer with R8, hence, no send-label. However, looking at interface Fa1/1, you see that it's in a VRF AND it's using LDP with R8 to send the labels.