Saturday, July 17, 2010

IPX Vol 1 - Lab 13 - QoS


This lab focuses on QoS, including MQC, Rate-limit, Multicast Rate-limit, WFQ, and WRED.

Here are some things that I need to watch out for.

Task 13.4 and 13.5 - Generic Traffic Shaping

This task specifically says to configure GTS for Frame Relay. In order to configure GTS for FR, you need ACLs to classify traffic, and then under the interface use the "traffic-shape" command.

And to verify, see below.

Config:

R4#
R4#sh run | sec access-list
access-list 101 permit tcp any any eq telnet
access-list 101 permit tcp any eq telnet any
access-list 101 permit icmp any any
access-list 102 permit tcp any any eq ftp
access-list 102 permit tcp any eq ftp any
access-list 103 permit ip any any
alias exec sa sh access-list
R4#
R4#
R4#sh run int s1/0.24
Building configuration...

Current configuration : 294 bytes
!
interface Serial1/0.24 point-to-point
bandwidth 64
ip address 150.50.24.1 255.255.255.252
snmp trap link-status
traffic-shape group 101 9600 7968 7968 1000
traffic-shape group 102 32000 8000 8000 1000
traffic-shape group 103 22400 7952 7952 1000
frame-relay interface-dlci 401
end

R4#
R4#sh traffic-shape s1/0.24

Interface Se1/0.24
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
- 101 9600 1992 7968 7968 885 996 -
- 102 32000 2000 8000 8000 250 1000 -
- 103 22400 1988 7952 7952 361 994 -
R4#

Also, in order to configure Adaptive GTS

Config:

R5#
R5#sh run int s1/0.56
Building configuration...

Current configuration : 240 bytes
!
interface Serial1/0.56 point-to-point
ip address 150.50.56.1 255.255.255.252
snmp trap link-status
traffic-shape rate 64000 8000 8000 1000
traffic-shape adaptive 32000
traffic-shape fecn-adapt
frame-relay interface-dlci 506
end

R5#



Task 13.7 - CAR

Remember, when a task says CAR, use the rate-limit command. Using ACLs to classify traffic and then combining it with the interface rate-limit command and the direction you can accomplish a single bucket policing.


Task 13.8 - Multicast Rate-limit

This tasks ask you to rate limit the incoming multicast traffic from a range of multicast groups,
226.0.0.1 to 226.0.0.126.


Config:
#sh run int f1/0
Building configuration...

Current configuration : 142 bytes
!
interface FastEthernet1/0
ip address 150.50.12.1 255.255.255.0
ip multicast rate-limit in group-list 25 512
duplex auto
speed auto
end

R1#sh run | sec access-list
access-list 25 deny 226.0.0.127
access-list 25 deny 226.0.0.0
access-list 25 permit 226.0.0.0 0.0.0.127
alias exec sa sh access-list
R1#