Sunday, July 18, 2010

IPX Vol 1 - Lab 15 - L2 VPN

Task 15.2 - Configure Frame-Relay DLCI-to-DLCI switching on R4 and R5...

Notes: Remember that the "ip local interface..." needs to be reachable, ie, make sure it's in OSPF in this case.

Also keep in mind that L2TPv3 is found on the Doc CD under 12.4 WAN.


Config:
R4
R4#sh run | sec pseudo
pseudowire-class MYWIRE
encapsulation l2tpv3
ip local interface Loopback0
R4#sh run int s1/0
Building configuration...

Current configuration : 162 bytes
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 402 switched
no frame-relay inverse-arp
end

R4#sh run | sec connect
connect R6_R2 Serial1/0 402 l2transport
xconnect 200.0.0.5 5544 pw-class MYWIRE
!
R4#sh run | sec ospf
router ospf 1
log-adjacency-changes
network 150.50.45.1 0.0.0.0 area 0
network 200.0.0.4 0.0.0.0 area 0

Verification:
R4#show l2tun session brief

L2TP Session Information Total tunnels 1 sessions 1

LocID TunID Peer-address State Username, Intf/
sess/cir Vcid, Circuit
19171 43255 200.0.0.5 est,UP 5544, Se1/0:402
R4#show l2tun session

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
19171 48468 43255 5544, Se1/0:402 est 00:05:20 1
R4#

R5
R5#
R5#sh run | sec pseudo
pseudowire-class MYWIRE
encapsulation l2tpv3
ip local interface Loopback0
R5#sh run int s1/0
Building configuration...

Current configuration : 162 bytes
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 506 switched
no frame-relay inverse-arp
end

R5#sh run | sec connect
connect R6_R2 Serial1/0 506 l2transport
xconnect 200.0.0.4 5544 pw-class MYWIRE
!
R5#sh run | sec ospf
router ospf 1
log-adjacency-changes
network 150.50.0.0 0.0.255.255 area 0
network 200.0.0.5 0.0.0.0 area 0




Task 15.3 - Q-in-Q Tunneling on Cat switches
Don't have switches right now.

Task 15.4 - Ethernet L2TPv3 on R1 and R4...

Notes: Same as 15.2, remember to advertise the loopback interface if you're using it in the pseudowire-class. Also, for Ethernet, you can make an xconnect statement right under the FE interface, rather then making a global connect statement

Config:
R1
!
pseudowire-class MYWIRE
encapsulation l2tpv3
ip local interface Loopback0
!
!
!
!
!
interface Loopback0
ip address 200.0.0.1 255.255.255.255
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
xconnect 200.0.0.4 1144 pw-class MYWIRE
!


Task 15.6 PPPoE

Notes: When you configure PPPoE, one side is the PPPoE client and the other side, the server. Configurations are different.

Configs:
R7 - Client Side
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1

!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
!

R9 - Server Side

!
bba-group pppoe global
virtual-template 1
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
pppoe enable group global
!
interface Virtual-Template1
ip address 150.50.79.9 255.255.255.0
peer default ip address pool R7
!
ip local pool R7 150.50.79.7

[Can't find Doc CD Ref]