Tuesday, August 3, 2010

INE Vol 1 - Lab 11 - OSPF Sham Link

Notes: OSPF Sham link is a "virtual link" between 2 PEs, this is used because the CE-PE protocol is OSPF and it gets redistributed into MP-BGP and then back to OSPF making the routes over MPLS WAN an Inter Area route. The backdoor connection is an Intra Area route and would always take precedence. To over come this, the Sham link is created between the 2 PEs and the the routes no longer are Inter Area routes.

Some things to remember, create a new loopback on the PEs and put them in the VRF, the advertise the Loopback interfaces in the IPv4 VRF in BGP to create reachability. Also remember to add a high OSPF cost on the backdoor link.

Configs:

R3#sh run | b router os
router ospf 1 vrf R6-SW1
log-adjacency-changes
area 0 sham-link 10.1.3.3 10.1.4.4
redistribute bgp 1 subnets
network 10.1.37.3 0.0.0.0 area 0
!
router isis
net 00.0000.0000.0003.00
is-type level-2-only
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 1
neighbor 150.1.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.4.4 activate
neighbor 150.1.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf R6-SW1
redistribute ospf 1 vrf R6-SW1
no synchronization
network 10.1.3.3 mask 255.255.255.255
exit-address-family

!
interface Loopback1
ip vrf forwarding R6-SW1
ip address 10.1.3.3 255.255.255.255
end

R3#