Sunday, July 25, 2010

IPX Vol 1 - Lab 24 - Multicast VPN

[DOC CD REF] ** This is a good review of Multicast VPN

Note: Referring to the Doc CD, in the IOS I'm currently using (12.4(20T)), it's required that under BGP, I have to configure BGP MDT SAFI, activate neighbors and send-community.

Excerpt:

Configuring the MDT Address Family in BGP for Multicast VPN

Perform this task to configure an MDT address family session on PE routers to establish MDT peering sessions for MVPN.

The mdt keyword has been added to the address-family ipv4 command to configure an MDT address-family session. MDT address-family sessions are used to pass the source PE address and MDT group address to PIM using Border Gateway Protocol (BGP) MDT Subaddress Family Identifier (SAFI) updates.

Config:

router bgp 256
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 200.0.0.5 remote-as 256
neighbor 200.0.0.5 update-source Loopback0
neighbor 200.0.0.6 remote-as 256
neighbor 200.0.0.6 update-source Loopback0
!
address-family ipv4 mdt
neighbor 200.0.0.5 activate
neighbor 200.0.0.5 send-community extended
neighbor 200.0.0.6 activate
neighbor 200.0.0.6 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 200.0.0.5 activate
neighbor 200.0.0.5 send-community extended
neighbor 200.0.0.6 activate
neighbor 200.0.0.6 send-community extended
exit-address-family
!
address-family ipv4 vrf VPNA
redistribute ospf 1 vrf VPNA
no synchronization
exit-address-family
!



Task 24.9 - Configure PIM sparse-mode on PE to PE links and loopbacks, configure SSM for multicast range 239.1.1.0 to 239.1.1.255, configure PIM spare-dense on VPN facing interfaces.



Config:

R2#sh run | sec pim|interface

interface Loopback0

ip address 200.0.0.2 255.255.255.255

ip pim sparse-mode

interface Serial1/0

no ip address

encapsulation frame-relay

serial restart-delay 0

no frame-relay inverse-arp

interface Serial1/0.24 point-to-point

ip vrf forwarding VPNA

ip address 150.50.24.2 255.255.255.252

ip pim sparse-dense-mode

snmp trap link-status

frame-relay interface-dlci 104

interface Serial1/0.25 point-to-point

ip address 150.50.25.2 255.255.255.252

ip router isis

ip pim sparse-mode

snmp trap link-status

mpls ip

frame-relay interface-dlci 105

interface Serial1/0.26 point-to-point

ip address 150.50.26.2 255.255.255.252

ip router isis

ip pim sparse-mode

snmp trap link-status

mpls ip

frame-relay interface-dlci 106

ip pim ssm range 1

ip pim vrf VPNA rp-address 200.0.0.4

R2#

R2#sh run | i access-list

access-list 1 permit 239.1.1.0 0.0.0.255

R2#Sh run | i multicast

ip multicast-routing

ip multicast-routing vrf VPNA

R2#


Task 24.10 - Enable VPNA for Multicast Routing... configure a default MDT and configure an RP address


Notes:

Here you have enable multicast for the VRF under multicast and enable MDT (multicast distribution tree) under the VRF. Finally, for a specific VRF you can specify the rp-address.

Config:

R2#Sh run | i multicast

ip multicast-routing

ip multicast-routing vrf VPNA

R2#

ip vrf VPNA

rd 256:1

route-target export 256:1

route-target import 256:1

mdt default 239.1.1.1

R2#sh run | sec rp-address

ip pim vrf VPNA rp-address 200.0.0.4

R2#


Task 24.11 - Configure PIM Sparse-Dense on SP facing interfaces on R1..., configure R1 to be a member of group 239.2.2.1...


Notes:

This is basic Multicast configurations.


Config:

R1#sh run | i multicast|rp-address|interface|pim|igmp

ip multicast-routing

interface Loopback0

interface FastEthernet0/0

interface FastEthernet1/0

ip pim sparse-dense-mode

ip igmp join-group 239.2.2.1

interface FastEthernet1/1

ip pim rp-address 200.0.0.4

R1#