Monday, August 9, 2010

INE Vol 1 - Lab 17 - CSC IP only Customer Carrier

Notes:
The purpose of this lab was to utilize another carrier as transport for a customer carrier to provide IP services to their end customers, presumably enterprise clients. The SP carrier uses R2 and R4 and BGP between them as well as MPLS and MPLS VPNs down to R1 and R5 (the customer carrier's upstream routers). Being how this is an "IP Only" Customer Carrier BGP was only ipv4, however, R2 and R4 were VPNv4 for label transport/MPLS VPN.

I attempted to configure this lab and all the previous labs just from the Objective and the diagram without reading the specific tasks, this one was a difficult in doing that because the peering between BGP ASes was evident from the diagram. I ended up trying to peer AS1 and AS2 but instead should have redistributed OSPF vrf into ipv4 bgp vrf... etc.

This is a great lab to review again.

Configs:
R2 - SP Carrier Router
R2#sri s1/0.21
Building configuration...

Current configuration : 172 bytes
!
interface Serial1/0.21 point-to-point
ip vrf forwarding AS1
ip address 150.1.12.2 255.255.255.0
snmp trap link-status
mpls ip
frame-relay interface-dlci 201
end

R2#sri f2/0
Building configuration...

Current configuration : 104 bytes
!
interface FastEthernet2/0
ip address 150.1.24.2 255.255.255.0
duplex auto
speed auto
mpls ip
end

R2#srb
router ospf 1 vrf AS1
log-adjacency-changes
redistribute bgp 2 subnets
network 150.1.12.2 0.0.0.0 area 0
!
router ospf 100
log-adjacency-changes
network 150.1.24.2 0.0.0.0 area 0
!
router bgp 2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.12.1 remote-as 1
neighbor 150.1.24.4 remote-as 2
!
address-family vpnv4
neighbor 150.1.24.4 activate
neighbor 150.1.24.4 send-community extended
exit-address-family
!
address-family ipv4 vrf AS1
redistribute ospf 1 vrf AS1
no synchronization
exit-address-family

R1 - Customer Carrier Router
R1#sri s1/0.12
Building configuration...

Current configuration : 149 bytes
!
interface Serial1/0.12 point-to-point
ip address 150.1.12.1 255.255.255.0
snmp trap link-status
mpls ip
frame-relay interface-dlci 102
end

R1#sri s1/1
Building configuration...

Current configuration : 88 bytes
!
interface Serial1/1
ip address 150.1.13.1 255.255.255.0
serial restart-delay 0
end

R1#srb
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.2.2 remote-as 2
neighbor 150.1.2.2 update-source Loopback0
neighbor 150.1.5.5 remote-as 1
neighbor 150.1.5.5 update-source Loopback0
neighbor 150.1.13.3 remote-as 1
!
address-family ipv4
neighbor 150.1.5.5 activate
neighbor 150.1.5.5 route-reflector-client
neighbor 150.1.13.3 activate
neighbor 150.1.13.3 route-reflector-client
no auto-summary
no synchronization
exit-address-family

R3 - Customer Provider Edge Router
R3#srb
router ospf 1
log-adjacency-changes
network 150.1.3.3 0.0.0.0 area 0
network 150.1.13.3 0.0.0.0 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.1.37.7 remote-as 65001
neighbor 150.1.13.1 remote-as 1
!
address-family ipv4
neighbor 10.1.37.7 activate
neighbor 150.1.13.1 activate
neighbor 150.1.13.1 next-hop-self
no auto-summary
no synchronization
exit-address-family
!