Monday, August 9, 2010

INE Vol 1 - Lab 18 - CSC MPLS enabled Customer Carrier

Notes:
This Lab was much more intuitive, probably from struggling and figuring out the previous lab, and I was able to configure the topology without viewing the instructions. From the Objective and from the diagram, I understood that the Customer Carrier was supporting MPLS and MPLS VPNs, the Provider Carrier didn't change much as they too support MPLS VPNs. Providing IGP transport for R3 and R6, the Customer Carrier's PE routers, was straight forward. Since R3 and R6 participate in OSPF and R2 and R4's link into OSPF was through a VRF, redistribution for Carrier Providers PE's was necessary. Once R3 had reachability to R6, vpnv4 iBGP was established spanning the Provider Carrier's network. Finally, putting the Customer PE interfaces into a vrf for PE-CE connectivity and establishing eBGP with the Enterprise client routers, full reachability was established.

Remember to ensure MPLS is enabled through out the network up until the Enterprise connectivity links.

Configs:
R2 - Provider Carrier's PE
R2#srb
router ospf 100 vrf AS1
log-adjacency-changes
redistribute bgp 2 subnets
network 150.1.12.2 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 150.1.24.2 0.0.0.0 area 0
!
router bgp 2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.24.4 remote-as 2
!
address-family vpnv4
neighbor 150.1.24.4 activate
neighbor 150.1.24.4 send-community extended
exit-address-family
!
address-family ipv4 vrf AS1
redistribute ospf 100 vrf AS1
no synchronization
exit-address-family

R3 - Customer Carrier's PE
R3#srb
router ospf 1
log-adjacency-changes
network 150.1.3.3 0.0.0.0 area 0
network 150.1.13.3 0.0.0.0 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.6.6 remote-as 1
neighbor 150.1.6.6 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.6.6 activate
neighbor 150.1.6.6 send-community extended
neighbor 150.1.6.6 next-hop-self
exit-address-family
!
address-family ipv4 vrf CUST
neighbor 10.1.37.7 remote-as 65001
neighbor 10.1.37.7 activate
no synchronization
exit-address-family
!