Friday, August 13, 2010

INE Vol 1 - Lab 22 MPLS TE - Dynamic PE to PE tunnels

Notes:

Remember to configure the bandwidth statement on serial interfaces, this is especially important if you plan on using RSVP and reserving a large amount of BW because you won't be able to reserve say 10 Megs if the serial link is only 1.5 Meg.

Summary of configuration steps:
1. Enable MPLS Traffic Engineering tunnels globally
2. Ensure the Link State protocol is configured to support Traffic Engineering Tunnels and remember to use a /32 router-id loopback for MPLS TE
3. Ensure the links are configured for RSVP and MPLS TE
4. Create Tunnel Interfaces; use ip unnumbered for address, set a tunnel destination IP (the other loopback), autoroute announce so the tunnel is in the IGP, set bandwith, priority, and path-options.

Don't forget that the destination IPs need to be in IGP as well as do the MPLS TE router-ids. And that TE is unidirectional.

Configs:
R3 - PE and Tunnel Head End

R3#sh run | b no ipv6
no ipv6 cef
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
!
archive
log config
hidekeys
!
interface Loopback0
ip address 150.1.3.3 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 150.1.4.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 6 6
tunnel mpls traffic-eng bandwidth 10000
tunnel mpls traffic-eng path-option 1 dynamic
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 155000
ip address 150.1.13.3 255.255.255.0
mpls traffic-eng tunnels
mpls ip
serial restart-delay 0
ip rsvp bandwidth 155000 155000

interface FastEthernet2/0
ip vrf forwarding SW1-SW2
ip address 10.1.37.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 150.1.0.0 0.0.255.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 1
neighbor 150.1.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.4.4 activate
neighbor 150.1.4.4 send-community extended
neighbor 150.1.4.4 next-hop-self
exit-address-family
!
address-family ipv4 vrf SW1-SW2
neighbor 10.1.37.7 remote-as 2
neighbor 10.1.37.7 activate
no synchronization
exit-address-family
!
ip forward-protocol nd

Verify:
R3#sh mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 1716 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 216 seconds
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
R3_t0 150.1.4.4 - Se1/0 up/up
R4_t0 150.1.3.3 Se1/0 - up/up
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails
R3#

Good Reference