Saturday, August 14, 2010

INE Vol 1 - Lab 23 - MPLS TE Explicit PE to PE tunnels

Notes:

*** Rule of thumb to simplify this configuration. After the MPLS VPN network is setup, think of it as overlaying TE on top. Go from General to Specific, meaning General = enabling MPLS TE on a global level, router wide. Then go to more Specific, like enabling MPLS TE in the link state IGP routing protocol, and then even more specific on the interfaces enabling RSVP and TE and then last step create the tunnel interfaces.

This lab is identical to the previous except for the TE tunnels using an explicit path list, hop by hop list, instead of a dynamic path like the last lab.

REMEMBER, the next-address is the next hop's inbound interface (looking from a downstream perspective).

Config:
R3 - PE and Tunnel head end
R3#sh run | b ipv6
no ipv6 cef
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
!
interface Loopback0
ip address 150.1.3.3 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 150.1.4.4
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 4 4
tunnel mpls traffic-eng bandwidth 10000
tunnel mpls traffic-eng path-option 1 explicit name PATH
no routing dynamic
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 155000
ip address 150.1.13.3 255.255.255.0
mpls traffic-eng tunnels
mpls ip
fair-queue 64 256 313
serial restart-delay 0
ip rsvp bandwidth 10000
!
interface FastEthernet2/0
ip vrf forwarding SW1-SW2
ip address 10.1.37.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 150.1.0.0 0.0.255.255 area 0
!
router bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 1
neighbor 150.1.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.4.4 activate
neighbor 150.1.4.4 send-community extended
neighbor 150.1.4.4 next-hop-self
exit-address-family
!
address-family ipv4 vrf SW1-SW2
neighbor 10.1.37.7 remote-as 2
neighbor 10.1.37.7 activate
no synchronization
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name PATH enable
next-address 150.1.13.1
next-address 150.1.12.2
next-address 150.1.25.5
next-address 10.1.45.4
next-address 150.1.4.4
!
logging alarm informational
!